izmit escort escort ankara adana escort

 FAQ •  Search •  Register •  Login 

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: SAM-BA v2.13 Issues with Loading/Running
PostPosted: Fri Mar 17, 2017 6:27 pm 
Offline

Joined: Mon Apr 13, 2015 9:10 pm
Posts: 12
Hi,

Seems like I'm having a problem loading up the main window in SAM-BA v2.13 after connecting my SAM3U USB CDC device. When I run SAM-BA in GUI mode, everything works fine with a JTAG connection; connection is valid, main window appears after connection. However, the USB CDC virtual COM port never connects when selected as an option.

I've tried to debug this issue by running command scripts to see what's going on. When I try running a command script for the JTAG, I run into a low level initialization issue which causes the applet to not load. When running a command script for USB CDC com port, it seems like the USB serial connection is never found / connected to SAM-BA, thus causing some infinite loop/lock (SAM-BA still shows it's running in my task manager after trying to connect it). I would assume (from reading the documentation) that I do not have to program any additional code for the USB CDC since SAM-BA Bootloader is in SAM3/4 family ROMs.

My two questions are:
1) What is the proper command script to load up the applet? This is what I see for one of the examples:
Code:
sam-ba.exe \jlink\ARM0 AT91SAM9G15-EK at91sam9g15ek_nandflash.tcl > logfile.log 2>&1
notepad logfile.log
I've also listed my command scripts below.


2) If my command script (listed below) is correct, why is the connection never made?

This is the log file of when I run my JTAG through the command line:
Code:
sam-ba.exe \jlink\ARM0 AT91SAM3U4-EK ./tc_lib\at91sam3u4-ek\at91sam3u4-ek.tcl > "..\..\..\Users\Me\Desktop.log.txt

-I- Waiting ...
-I- TCL platform : Windows NT
-I- SAM-BA 2.13  on : windows
-I- current connection is \jlink\ARM0, \\jlink\\ARM0 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \jlink\ARM0
-I- argv 1 : AT91SAM3U4-EK
-I- argv 2 : ./tcl_lib\at91sam3u4-ek\at91sam3u4-ek.tcl
-I- Connection \jlink\ARM0
-I- Connect index 0 in connection list
-I- Connecting with \jlink\ARM0\SN:28017453
-I- Connection : \jlink\ARM0\SN:28017453 (target(comType) = 2)
-I- Board : at91sam3u4-ek
-I- Traces Level : 4
-I- target(handle) : 45713448
-I- sourcing board description file C:/Program Files (x86)/Atmel/sam-ba_2.13/sam-ba.exe/../tcl_lib/at91sam3u4-ek/at91sam3u4-ek.tcl
Read device Chip ID at 0x400E0740 --- get 0x28100961
-I- Found chip : at91sam3u4_1 (Chip ID : 0x28100961)
-I- Loading applet applet-lowlevelinit-at91sam3u4.bin at address 0x20001000
-E- Error during Low level initialization.
-E- Low level initialization is required to run applets.
-E- Connection abort!


And this is the log file when I run my USB CDC:
Code:
sam-ba.exe \USBserial\COM17 AT91SAM3U4-EK ./tc_lib\at91sam3u4-ek\at91sam3u4-ek.tcl > "..\..\..\Users\Me\Desktop.log.txt"

-I- Waiting ...
-I- TCL platform : Windows NT
-I- SAM-BA 2.13  on : windows
-I- current connection is \USBserial\COM17, \\USBserial\\COM17 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \USBserial\COM17
-I- argv 1 : AT91SAM3U4-EK
-I- argv 2 : ./tcl_lib\at91sam3u4-ek\at91sam3u4-ek.tcl
-I- Connection \USBserial\COM17


Will supply more info if needed. Thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: SAM-BA v2.13 Issues with Loading/Running
PostPosted: Fri Mar 17, 2017 11:08 pm 
Offline

Joined: Thu Apr 19, 2007 10:15 pm
Posts: 1419
Location: USA
yun wrote:
Seems like I'm having a problem loading up the main window in SAM-BA v2.13 after connecting my SAM3U USB CDC device.
You have already been warned that the SAM-BA utility would not interact with your program unless your program emulated the command set.

yun wrote:
When I run SAM-BA in GUI mode, everything works fine with a JTAG connection
...
When I try running a command script for the JTAG, I run into a low level initialization issue
Apparently you don't understand the meaning of "everything works", and contradict yourself.

yun wrote:
I would assume (from reading the documentation) that I do not have to program any additional code for the USB CDC since SAM-BA Bootloader is in SAM3/4 family ROMs.
You assume incorrectly.
The code in ROM is irrelevant if the processor is busy executing your program.
Read the datasheet for "boot strategies" and the specific procedure to initiate execution of the SAM-BA Monitor program.

Regards


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: Baidu [Spider] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron