[Solved]9263 SD Card problem,status 0x8085

This forum is for users of Atmel's SAM Series and who are interested in using WinCE OS.

Moderator: nferre

misswhile
Posts: 8
Joined: Thu Jul 29, 2010 1:21 pm

[Solved]9263 SD Card problem,status 0x8085

Mon Aug 23, 2010 10:39 am

with at91sam9263,wince5.0 bsp
when insert sd card,got message as below:
SD/MMC card insertion detected on Slot A
SDMMC:InitDisk with pDisk 0xd1126860
SDCard Initialisation Successful
Master Clock is 89856000 Hz
ConfigClockFromRegistry : Clock is too high. Clipping it to 15000000 Hz
ConfigClockFromRegistry : Computed Clock = 14976000 Hz
WaitForSingleObject == WAIT_TIMEOUT (208)
StatusMask = 0x8
status 0x8085
WaitForStatus error status = 0x8085
read multiple Prb
WaitForSingleObject == WAIT_TIMEOUT (208)
StatusMask = 0x8
status 0x8085
WaitForStatus error status = 0x8085
read multiple Prb
WaitForSingleObject == WAIT_TIMEOUT (208)
StatusMask = 0x8
status 0x8085
WaitForStatus error status = 0x8085
read multiple Prb
...
...
WaitForStatus error status = 0x8085
read multiple Prb
ReadData : retry 10
SDMMC:DoDiskIO - ReadData failed
SD/MMC card removal detected on Slot A (at this point,i removed the card)

And i also test wince6.0,
i got these message, when insert she sd card:

SDHCSetRate - Actual clock rate = 175480
FastPath requets failed
FastPath requets failed
FastPath requets failed
cable attached
SDHCSetRate - Actual clock rate = 175480
SDHCSetRate - Actual clock rate = 175480
FastPath requets failed
FastPath requets failed
FastPath requets failed
FastPath requets failed
NOT ready !!! 0xc0c5
SDHCSetRate - Actual clock rate = 22461504
FastPath requets failed
FastPath requets failed


I have check the pin on the board,as belown:
{"MCI1DA0", AT91C_PIN_PA(8), 0, PIO_PULLUP, PIO_PERIPH_A},
{"MCI1CDA", AT91C_PIN_PA(7), 0, PIO_DEFAULT, PIO_PERIPH_A},
{"MCI1CK", AT91C_PIN_PA(6), 0, PIO_PULLUP, PIO_PERIPH_A},
{"MCI1DA1", AT91C_PIN_PA(9), 0, PIO_PULLUP, PIO_PERIPH_A},
{"MCI1DA2", AT91C_PIN_PA(10), 0, PIO_PULLUP, PIO_PERIPH_A},
{"MCI1DA3", AT91C_PIN_PA(11), 0, PIO_PULLUP, PIO_PERIPH_A},

ps. sd works well in linux.

Thank you!


solved, the pin not weld well,after reweld,it ok.

Return to “WinCE”

Who is online

Users browsing this forum: No registered users and 4 guests