SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Discussion around products based on ARM Cortex-A5 core.

Moderator: nferre

micro1
Posts: 42
Joined: Sun Jun 08, 2014 11:55 am

SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Fri Jan 01, 2016 3:12 pm

SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0.
This is also with Buildroot

That means fb0 is present but does not work correct monitor shows incompatible HDMI input.

Mybee its the same issue due to new at91bootstrap freuquenz changes to 600 MHZ
micro1
Posts: 42
Joined: Sun Jun 08, 2014 11:55 am

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Fri Jan 01, 2016 8:29 pm

Only with the following Bootstrap und Uboot it works

AT91Bootstrap 3.7.2 (Tue May 12 09:38:47 CEST 2015)


EEPROM: Loading AT24xx information ...
EEPROM: BoardName | [Revid] | VendorName

1-Wire: Using default information

1-Wire: Board sn: 0x1012420, revsion: 0x680820

Auto-Config the TWI Bus by the board
HDMI SiI9022: Enter D3 Cold mode
PHY: ETH0 PHY: Enter power down mode
NAND: ONFI flash detected
NAND: Manufacturer ID: 0x2c Chip ID: 0x34
NAND: Disable On-Die ECC
NAND: Initialize PMECC params, cap: 0x8, sector: 0x200
NAND: Image: Copy 0x80000 bytes from 0x40000 to 0x26f00000
NAND: Done to load image


U-Boot 2015.01-linux4sam_4.7 (May 12 2015 - 15:53:26)

CPU: SAMA5D44
Crystal frequency: 12 MHz
CPU clock : 528 MHz
Master clock : 176 MHz
I2C: ready
DRAM: 512 MiB
I2C: ACT8865 series can not be accessed
NAND: 512 MiB
MMC: mci: 0
In: serial
Out: serial
Err: serial
Net: gmac0, usb_ether
Error: usb_ether address not set.
micro1
Posts: 42
Joined: Sun Jun 08, 2014 11:55 am

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Fri Jan 01, 2016 8:30 pm

Only with the following Bootstrap und Uboot it works

AT91Bootstrap 3.7.2 (Tue May 12 09:38:47 CEST 2015)


EEPROM: Loading AT24xx information ...
EEPROM: BoardName | [Revid] | VendorName

1-Wire: Using default information

1-Wire: Board sn: 0x1012420, revsion: 0x680820

Auto-Config the TWI Bus by the board
HDMI SiI9022: Enter D3 Cold mode
PHY: ETH0 PHY: Enter power down mode
NAND: ONFI flash detected
NAND: Manufacturer ID: 0x2c Chip ID: 0x34
NAND: Disable On-Die ECC
NAND: Initialize PMECC params, cap: 0x8, sector: 0x200
NAND: Image: Copy 0x80000 bytes from 0x40000 to 0x26f00000
NAND: Done to load image


U-Boot 2015.01-linux4sam_4.7 (May 12 2015 - 15:53:26)

CPU: SAMA5D44
Crystal frequency: 12 MHz
CPU clock : 528 MHz
Master clock : 176 MHz
I2C: ready
DRAM: 512 MiB
I2C: ACT8865 series can not be accessed
NAND: 512 MiB
MMC: mci: 0
In: serial
Out: serial
Err: serial
Net: gmac0, usb_ether
Error: usb_ether address not set.
abelloni
Posts: 15
Joined: Sat May 03, 2014 7:34 pm

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Tue Mar 01, 2016 3:41 pm

This is a known issue, you have to use linux-at91 3.18 to have HDMI working. Work is ongoing to get it upported.
micro1
Posts: 42
Joined: Sun Jun 08, 2014 11:55 am

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Tue Mar 01, 2016 5:29 pm

abelloni wrote:This is a known issue, you have to use linux-at91 3.18 to have HDMI working. Work is ongoing to get it upported.

Thank this is good. But can you explain me where i can find the issue list who this issue is written down?
blue_z
Location: USA
Posts: 1638
Joined: Thu Apr 19, 2007 10:15 pm

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Tue Mar 01, 2016 9:33 pm

It's mentioned in the 2016 January Linux Newsletter

The absence of the required driver for the Sii9022a HDMI chip is the salient indicator.
Same goes for the video decoder of the SAMA5D4.

Regards
blue_z
Location: USA
Posts: 1638
Joined: Thu Apr 19, 2007 10:15 pm

Linux4SAM_5.3 kernel restores HDMI functionality

Wed Apr 20, 2016 3:16 am

HDMI functionality works (again) on the SAMA5D4-XULT with the recently-released Linux4SAM_5.3 kernel (based on 4.1.0).
Works with AT91Bootstrap 3.8.5, U-Boot 2016.03-linux4sam_5.3, and CPU clock at 600 MHz.

Regards
nferre
Site Admin
Posts: 172
Joined: Wed Feb 14, 2007 11:17 am

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Fri Apr 22, 2016 10:43 am

Hi,

Thanks blue_z for having relayed the information here: I'm sure it's very valuable to the people of this thread.

Bye,
micro1
Posts: 42
Joined: Sun Jun 08, 2014 11:55 am

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Mon Apr 25, 2016 10:28 pm

Hi,

thanks for the information. I have tested it with the prebuild sd card images with yocto. This works.


But with buildroot it does not work. Have you tested it also with buildroot?


Best regards

Jens
micro1
Posts: 42
Joined: Sun Jun 08, 2014 11:55 am

Re: SAMA5D4 Xplained HDMI fails also with Linux4Sam demo 5.0

Tue Apr 26, 2016 8:00 pm

Hello,

sorry it works. But the env Settings are incorrect for the U-Boot in buildroot.

This are the correct Settings

bootargs=console=ttyS0,115200 root=/dev/mmcblk0p2 rw rootfstype=ext4 rootwait video=HDMI-A-1:800x600-16

bootcmd=fatload mmc 0:1 0x21000000 at91-sama5d4_xplained_hdmi.dtb; fatload mmc 0:1 0x22000000 zImage; bootz 0x22000000 - 0x21000000

Return to “SAMA5D Cortex-A5 MPU”

Who is online

Users browsing this forum: No registered users and 1 guest