Page 1 of 1

USB File storage gadget on windows host

Posted: Thu Aug 25, 2005 6:44 pm
by damien83
Does someone can successfully use USB File storage gadget on a windows host ?

I try to do exactly what is on this page : http://www.linux-usb.org/gadget/file_storage.html but unfortunatly windows recognize the device as an USB Mass storage device, but does not show the disk. I try both on windows XP (vmware) and windows 2000 (true computer).

With Windows 2000 I can see the message "g_file_storage gadget: full spped config #1" which is repeated on my target, like if the device was connected/disconnected, connected/disconnected again and again.

On a linux host it works without any problem with the module usb-storage.

I'd like to know your experiences and if you have an idea where does it come from.

Thank you

Damien

Posted: Fri Aug 26, 2005 8:25 am
by Onitake
i suspect windows isn't recognizing the device's filesystem or partitioning...

can you post the contents of /proc/partitions (linux) when the stick is plugged in?

you may also use the drive manager (windows, My Computer -> Manage) to check if a disk has been attached. sometimes it detects the hardware correctly but for some reason doesn't mount the partition(s). happened when i had set the wrong filesystem id for a FAT32 partition once. linux doesn't care, but windows is very sensible here.

Posted: Fri Aug 26, 2005 10:12 am
by damien83
The content of /proc/partitions seems all right :

[root@damien damien]# cat /proc/partitions
major minor #blocks name

3 0 58652496 hda
3 1 8209183 hda1
3 2 1 hda2
3 5 1044193 hda5
3 6 49391811 hda6
8 0 65536 sda
8 1 65532 sda1

And there is nothing about my device in Compute/Manage on windows. Did you try yourself the file storage gadget on at91rm9200 successfully ?

Damien

Posted: Fri Aug 26, 2005 2:43 pm
by damien83
It's working with windows XP / Vmware, I just have to wait some time... But I have always nothing with Windows 2000 on a real computer.