at91rm9200ek serial console problem

This forum is for users of Microchip MPUs and who are interested in using Linux OS.

Moderator: nferre

Posts: 17
Joined: Sun Dec 11, 2005 1:17 am

at91rm9200ek serial console problem

Sun Dec 11, 2005 1:37 am

hello and welcome ;)
i've just received an at91rm9200-ek evaluation kit. i've got no additional monitor, so i'm using minicom attached to debug serial port.
it works well with openpda-on-mmc kernel, but with every other one it sends garbage :(

1. i've tried to boot an 'atmel linux' images as described here: Pages/gettingstarted/RM9200EK/page/linu ... step3.html and on the provided dvd-rom, but without success
2. i've tried to build my own 2.4.19-rmk7 and 2.4.27-vrs1 kernels. garbage :(

it looks like every kernel i build (and provided on dvd linux-ek and linux-dk also!) is doing someging werid with bit 0x20 or/and 0x02. when i type 'root' prompted for login i'm echoed back with 'pOOt'

what am i doing wrong?
Posts: 17
Joined: Sun Dec 11, 2005 1:17 am

Sun Dec 11, 2005 1:41 pm

ok, i've managed to get it work, by changing #define AT91C_MASTER_CLOCK 59904000 in at91rm9200ek.h from 59904000 to 44928000. but why i had to do that? :? :roll:

update: no changes are necessary when i boot by atmel dataflash loader/uboot. looks like 'open pda' bootloader sets clock to lower speed.
Posts: 12
Joined: Tue Mar 01, 2005 2:59 pm

Tue May 09, 2006 3:58 pm

Hi Liftboy,

I have tried 2.4.27-vrs1 , and it works fine with me. I build the tool-chain, kernel, everything from scratch. (my development platform is Fedora Core 5) Everything is minimal, and it can boot using NFS.


Return to “LINUX”

Who is online

Users browsing this forum: No registered users and 1 guest