Atmel ISI Reset Timeout, no Pixel Clock

This forum is for users of Microchip MPUs and who are interested in using Linux OS.

Moderator: nferre

Posts: 2
Joined: Wed Jun 07, 2017 4:39 pm

Atmel ISI Reset Timeout, no Pixel Clock

Wed Jun 07, 2017 7:47 pm

Hey guys.

I'm working with a custom board that has at AT91SAM9G25-EK at it's heart. We're connecting an OV5642 camera module via the ISI.
Everything works great on Linux 3.16, but we're porting our custom driver code and application to Linux 4.9.30.

I've got the camera up over I2C, and am feeding it a master clock in the device tree (the biggest change seems to be that the ISI no longer sets up the mclk/xvclk for the camera itself).

The device shows up as /dev/video0 and I can query capabilities. However when I run

Code: Select all

v4l2-ctl --device /dev/video0 --stream-mmap --stream-to=frame.raw --stream-count=1
to test image capture the ISI reset function (called from the start_streaming function) hits a timeout.

The comments claim this should only happen if the ISI doesn't have a pixel clock from the camera module. I'm pretty sure the camera is giving one back, but I haven't busted out the O-Scope yet.
I've tried increasing and ignoring the timeout but nothing is going on.
Anything I should try/check before I begin the arduous process of physically examining the signals?


Return to “LINUX”

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 11 guests