Error opening /dev/ttyS2: No such file or directory

This forum is for users of Microchip MPUs and who are interested in using Linux OS.

Moderator: nferre

thanhtrung
Posts: 3
Joined: Mon Nov 25, 2019 11:25 am

Error opening /dev/ttyS2: No such file or directory

Fri Jan 31, 2020 6:38 am

Hi all

I have a problem in setup USART with AT91SAM9G25.

I can open /dev/ttyS0 and S1, but I can't open /dev/ttyS2 or S3.

I know AT91SAM9G25 have USART2 and USART3, but I can't open it

How can I open USART2 and USART3

Please help me.

Thank you for your helping.
blue_z
Location: USA
Posts: 2033
Joined: Thu Apr 19, 2007 10:15 pm

Re: Error opening /dev/ttyS2: No such file or directory

Tue Feb 04, 2020 10:01 pm

thanhtrung wrote: I have a problem in setup USART with AT91SAM9G25.

I can open /dev/ttyS0 and S1, but I can't open /dev/ttyS2 or S3.
What board is this?
Have you confirmed that the PIOs for those two USARTs are actually available (or assigned to that function), and not used by any other peripheral?

thanhtrung wrote: I know AT91SAM9G25 have USART2 and USART3, but I can't open it
Seems like what you know is incomplete.
SoCs typically have many more peripherals than can be actually used when installed on a board (because of the limited number of pins/balls of the chip).
So first you have to check the board schematics to verify that the necessary PIOs for those USARTs are available (or review the board specification for which pins are multiplexed for those peripherals).

Regards

Return to “LINUX”

Who is online

Users browsing this forum: Google [Bot] and 9 guests