Page 1 of 1

WinCE problems on custom board

Posted: Sun Nov 27, 2005 12:53 pm
by PETN
Hi
I developed a custom board with AT91RM9200 and downloaded Adeset BSP binary files. I added S1D13A04 drivers (they can be found at Epson's website) and followed the guide ("Install note on EK") provided by Adeset.
Since my board doesn't support dataflash, I use U-Boot to boot the WinCE image (built with PlatformBuilder 5.0) with the command "go 20071000".
The WinCE image starts and I can see (and use with an USB keyboard) the shell but I have the following problems:
1) If I attach an USB mouse, I can't see the mouse pointer. (although I can click over the icons)
2) If I put a SD card in the SD card slot, no icons appear in "My Device" folder. (I added the needed drivers, because I followed the guide). In other words, I can't use the SD card.

What's wrong? Is Eboot required to start WinCE correctly? (I cannot use Eboot.nb0 provided with the BSP, because it hangs when it tries to access the dataflash).
Is any other driver missing?

My configuration is:
1) 8MB Flash NOR
2) 64 MB of SDRAM (but I use only 32MB because the BSP doesn't support 64MB)
3) SD Slots
4) USB host and device
5) S1D13A04 Display driver

Please help me!

Thanks in advance

PETN

Posted: Wed Nov 30, 2005 10:19 am
by Adeneo
Hi PETN,

Concerning the cursor, as you are using a different display controller, there might be some adaptations required in the epson driver for this, as Epson controllers can handle Hardware cursor

Another possibility is simply that you might miss the mouse component in your WinCE OS Design

Concerning SDCard, you'll need "storage manager" and "FAT File system" to be able to use SDCard. It might also be a detection issue : the EK board from Atmel does not have a PIO connected to SDCard connector for card insertion and removal detection. Consequently, we made a small graphical app. which can be used to declare manually card insertion and detection. When inserting a card in the slot, you have to use this app to signal the driver the insertion

BR
Yannick

Posted: Sun Dec 18, 2005 6:04 pm
by PETN
Hi

I solved the problem with the cursor, a flag was missing in the mode definition header file.

I have also installed the new BSP downloaded from Adeset's website (AT91RM9200EKCN Binary BSP for Windows CE 5.0): in this BSP there is a "Flash loader" utility but the drivers for the secure digital are missing...

I tried also to merge the sdmmc.dll and sdmmc_loader.dll files from the previous BSP, but WinCE cannot see my sd card (no icon appears on "my device").

How can I solve that?

Best Regards

Nicola

Posted: Tue Dec 27, 2005 5:34 pm
by Adeneo
EKCN BSP is dedicated to a specific Atmel board which has no SDCard driver. You should use the EK BSP which is also available on Adeset Website.

The EK board does not have a PIO connected to SDCard slot that could allow card insertion and removal detection. That's why we deliver with the BSP a "Flash loader" utility that can be used to signal to the driver card insertion & removal.

If you have a custom design, you might need the source version of the BSP to perform some adaptation. However, be aware that the binary version of the BSP is only an eval version that you should not use for commercial product. It is dedicated to demonstration & testing only