WinCE6.0 booting problem

This forum is for users of Atmel's SAM Series and who are interested in using WinCE OS.

Moderator: nferre

Posts: 12
Joined: Wed Jul 21, 2010 5:09 pm

WinCE6.0 booting problem

Fri Sep 10, 2010 3:05 pm


I posted a problem that I was having a while ago and did not receive a response; so I'm going to try again. :shock: Better luck this time I hope.

I have VS2005 installed and Platform Builder for CE6.0 installed.
I have an AT91SAM9260EK connected to Ethernet and a serial port on my PC.
I have SAMBA2.10 installed.

I've successfully managed to download FIRSTBOOT.nb0 and EBOOT.nb0 to the DataFlash on the EK. They work fine.

I've compiled an OS image from a cloned BSP from the AT91SAM9260EK_SRC_CE6_v110.msi installation.

1. I'm able to connect and download the image to the EK through the Ethernet from VS2005 and have the image stored on the NAND flash by EBOOT. The EK is able to start WinCE after a powerup. This is all well and good and works very well. However...

2. I would like to use SAMBA to download the OS image to the NAND flash and to have EBOOT load the image into SDRAM and start running from there. This all seems possible, but it never works!

I load the image (nk.nb0) to NAND flash using SAMBA 2.10 at address 0x20000.

When I powerup the EK, the FIRSTBOOT starts, EBOOT next. I can see the image (or something) being copied from NAND to SDRAM.

The message Launching Windows CE image by jumping to address 0x20068000 is displayed. The EK stops all activity and resets after a few seconds.

Why is this?

I've read all the posts on this forum about booting issues and there are many people asking the same sorts of questions that I ask with very little information provided by Adeneo.

It is not acceptable to be told that the only method of flashing an image is to use the Ethernet connection only.

I look forward to some information about this issue. Thanks! :)
Location: France - USA
Posts: 183
Joined: Fri May 14, 2004 9:58 am

Re: WinCE6.0 booting problem

Mon Sep 13, 2010 1:24 pm


It seems that you miss one step of the "AT91SAM9260EK CE6.0 Install Notes v1.1.0 B.pdf" file, section 5.5.2. This section describes the procedure to use SAM-BA to program an image and especially how to configure the settings of eboot (last item of sheet 16)


If this answer solves your problem, please edit the subject of this post by adding [Solved] at the beginning of the subject.
Posts: 12
Joined: Wed Jul 21, 2010 5:09 pm

Re: WinCE6.0 booting problem

Mon Sep 13, 2010 4:18 pm


Thank you for your response.

I used cvrtbin to create the nk.nb0 file from nk.bin using the same parameters that I put into the nand setup in Eboot.

In fact, I was putting in the correct nand settings! I just didn't mention it in my first post; the .pdf document you listed I have been reading again and again to try to get this system to work properly.

I've followed your instructions exactly as they are shown in 5.5.2, but the output result is still the same.

After the bootloaders have run correctly, the following message is displayed:

FMD_DirectRead OK.
Launching windows CE image by jumping to address 0x20068000

The target board then resets after a few seconds and the whole process loops.

The image runs on the target board when it is downloaded via Ethernet from VS2005.

Is SAMBA the problem perhaps?

Return to “WinCE”

Who is online

Users browsing this forum: No registered users and 2 guests