Page 1 of 1

AT91SAM9G45 and Ethernet download

Posted: Mon May 16, 2011 4:53 pm
by dvescovi
I have been working an issue with the 91SAM9G45 BSP (1.4). We have a custom board that is almost exactly like the EK board, same RAM same Flash etc. We have the Ethernet connect but I get UDP header checksum errors when I try to download from platform builder. The download always starts correctly but fails at exactly 2.2mb into the download with the same UDP error. After some searching some Internet posting suggested a hardware problem so I assumed it might be the Davicom Ethernet PHY. It was stated this part would occasionally give packet errors. We changed the part to a different manufacturer (Micrel). To my surprise it still fails at exactly the same place in the download. Next assuming it might be a memory problem, I moved things around and changed the stack size …no effect, same failure. Next thinking it might have something to do with the actual nk.bin file, I tried downloading a completely different nk.bin file from another build for another processor which I know works (just as a download test). It also failed at exactly 2.2mb download point with the same UDP error.
This must be an issue with ether the boot loader implementation or the software driver for the Ethernet MAC on the part.
Can anyone provide more insight on a possible solution or other tests I could perform?
Is there any known issues with this BSP?

Re: AT91SAM9G45 and Ethernet download

Posted: Wed May 18, 2011 10:12 pm
by dvescovi
Fixed it. Seems to be a memory problem.