[Solved] VS2005 not detecting the target device

This forum is for users of Atmel's SAM Series and who are interested in using WinCE OS.

Moderator: nferre

Posts: 4
Joined: Mon Feb 20, 2012 5:53 am

[Solved] VS2005 not detecting the target device

Thu Feb 23, 2012 7:27 am

Hi everyone,

First of all I'm very new to WinCE so i might be asking a very basic question.

I have a SAM9M10-G45 evaluation board and would like to load the sample project that came with the BSP.
I've followed steps described in Adeneo Windows CE 6.0 PORT on AT91SAM9G45M10EK app note: using the windows CE bsp.
I've managed to load Eboot.nb0 to NANDflash and now I would like to load the NK.bin through VS2005.

My problem is that under Target -> Connectivity Option, Download Settings, it never shows the development board as active target device, so I can't load it through VS2005. In the debug port it constantly says "Sent BOOTME to" and I can see that BOOTME packets are getting to my PC as I checked with Wireshark.

Could you please help me what i need to make VS2005 detect the device?
Could it possibly be related to my PC being Win7 64bit?

Last edited by atmel_elex on Wed Feb 29, 2012 5:47 am, edited 1 time in total.
Posts: 4
Joined: Mon Feb 20, 2012 5:53 am

Re: VS2005 not detecting the target device

Thu Feb 23, 2012 10:58 pm

Hi everyone,

Since yesterday I've been trying to load NK image on the board but no success. Thought the problem was with VS2005 but not very likely. I can't even load NK image when NK image is loaded to NAND flash using SAMBA. So I decided to go back to the very beginning by putting the recovery image. I've done the following:

1. Connect the board to SAMBA 2.11
2. Erase both NAND flash and Data flash
3. Close SAMBA and reboot the board (with correct jumper settings)
4. Make sure the virtual COM is established then close J10
5. Run Demo/demo-at91sam9m10g45ek.bat

After a little while message comes up saying
local disk drives list is e
WARNING: do not plug any USB key until EK board
is recognized as a removable disk
wait for EK board connection via USB...

Then finally comes up with message saying that it "Cannot find removable disk in 5 minutes, aborted"

logfile.log contains this, which sounds like it couldn't find the board..:
-I- Waiting ...
-I- TCL platform : Windows NT
-I- SAM-BA 2.11 on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : \usb\ARM0
-I- argv 1 : AT91SAM9M10-EK
-I- argv 2 : demo-at91sam9m10g45ek.tcl
-E- Board at91sam9m10-ek not found
-E- Supported boards : at91sam7a3-ek no_board at91sam9260-ek at91sam3s4-ek at91sam7xc512-ek at91cap7-stk at91sam3u4-ek at91sam7x256-ek at91cap9-stk at91sam7se512-ek at91sam9rl64-ek at91sam7s161-ek at91sam3x8-ek at91sam9263-ek at91sam7l64-ek at91sam7s256-ek at91sam9m10-ekes at91sam3s2-ek at91sam9x35-ek at91sam3n1-ek at91sam3u2-ek at91cap7-dk-mem33 at91sam9xe256-ek at91sam7se32-ek at91sam7xc128-ek at91sam9g15-ek at91sam7s32-ek at91sam7x512-ek at91cap9-dk-mem18 at91sam7s321-ek at91sam9g35-ek at91sam9g10-ek at91sam9g45-ekes at91sam9261-ek at91sam3n4-ek at91sam7l128-ek at91sam7s512-ek at91cap9-dk-mem33 at91sam9xe512-ek at91sam3s8-ek at91sam3x4-ek at91sam7x128-ek at91sam9n12-ek at91sam3n2-ek at91sam9m10-g45-ek at91sam7s64-ek at91sam7xc256-ek at91sam9x25-ek at91sam7se256-ek at91sam3s16-ek at91sam3x2-ek at91sam7s128-ek at91sam3s1-ek at91sam9g25-ek at91sam9xe128-ek at91sam3u1-ek at91sam7s16-ek at91sam3sd8-ek at91sam9g20-ek

After this, I checked the debug output of erasing NAND flash and found that it had a bad block!
-I- BATCH ERASE command
-I- Erase block from #1280 to #1536
-I- SkipBlockNandFlash_EraseBlock: Block is BAD
-I- Found block #1333 BAD, skip it
-I- Batch Erase achieved
-I- End of applet (command : 14 --- status : 0)

Is it this BAD block that's causing the recovery process to fail?
Also could I repair the BAD block in NAND flash through SAMBA?

If someone can help it'll be greatly appreciated as I've been battling with this for too long!

Thank you!
Posts: 4
Joined: Mon Feb 20, 2012 5:53 am

Re: VS2005 not detecting the target device

Wed Feb 29, 2012 5:47 am

Hi someone out there,

So I got the original image load up to my load successfully. I still have a bad block in NAND Flash but it seems not to mind it.
All I have to do was to change the target name in their batch file from AT91SAM9M10-EK to AT91SAM9M10-G45-EK. Suppose the log file did indicate this.

Now my main problem was the target not detected by the VS2005.
This seems to be fixed after I installed QFE and made sure that Platform builder was properly linked with VS2005. To check that, just go Tools -> Platform Builder -> CE Check Update and if Platform builder comes up you are ok but if it doesn't you have to change registries. I just downloaded a zip file from here (http://compulab.co.il/workspace/mediawi ... stallation).

Restarted VS2005 and clean built it, then after a while it started to detect the target.

So ya, if anyone faces some problems like mine, hope this helps.

Posts: 4
Joined: Mon Feb 20, 2012 5:53 am

Re: [Solved] VS2005 not detecting the target device

Thu Mar 01, 2012 10:27 pm

The real solution was actually disabling my firewall..

Happy coding!

Return to “WinCE”

Who is online

Users browsing this forum: No registered users and 2 guests