Launching winCE 5.0 image problem under Platform Builder

This forum is for users of Atmel's SAM Series and who are interested in using WinCE OS.

Moderator: nferre

Ildar
Posts: 2
Joined: Thu May 15, 2008 1:13 pm

Launching winCE 5.0 image problem under Platform Builder

Tue May 20, 2008 6:28 pm

Dears,
I use AT91SAM9261-Evaluation Kit with AT91SAM9261EK_BIN BSP, AT91-ISP v1.11.
I performed the actions described in AT91SAM9261EK CE5.0 Install Notes v1.7.0 A.pdf.
After image is downloaded error occures (with Kitl enabled) and there is no WinCE desktop displayed on the screen, no ActiveSync connection.

I attached 2 logs from Terminal window.
First log file corresponds to the project with the default build options:
-Enable CE Target Control Support
-Enable Eboot Space in Memory
-Enable Full Kernel Mode
-Enable Kitl
/******/
Master Clock is 58851431 Hz
Test : 0xe5e
g_oalTimer.msecPerSysTick : 0x1
g_oalTimer.countsPerMSec : 0xe5e
g_oalTimer.countsMargin : 0x0
g_oalTimer.maxPeriodMSec : 0x11c
g_oalTimer.countsPerSysTick : 0xe5e
g_oalTimer.actualMSecPerSysTick : 0x1
g_oalTimer.actualCountsPerSysTick : 0xe5e
g_oalTimer.curCounts : 0x0
Master Clock is 58851431 Hz
-OALTimerInit
+OEMPowerManagerInit
-OEMPowerManagerInit
avant OALKitlStart - force clean (@0x806e3af4 = 0x0) = FALSE
OALKitlStart
ERROR: Unable to locate Device ID buffer
+OALKitlInit('(NULL)', 0x0000000d - 0/0/0x30000000, 0x8068643c)
/*****/
Second log file corresponds to the project with the only build option:
-Enable Eboot Space in Memory
/******/
Master Clock is 58851431 Hz
Test : 0xe5e
g_oalTimer.msecPerSysTick : 0x1
g_oalTimer.countsPerMSec : 0xe5e
g_oalTimer.countsMargin : 0x0
g_oalTimer.maxPeriodMSec : 0x11c
g_oalTimer.countsPerSysTick : 0xe5e
g_oalTimer.actualMSecPerSysTick : 0x1
g_oalTimer.actualCountsPerSysTick : 0xe5e
g_oalTimer.curCounts : 0x0
Master Clock is 58851431 Hz
-OALTimerInit
+OEMPowerManagerInit
-OEMPowerManagerInit
avant OALKitlStart - force clean (@0x806bb614 = 0x0) = FALSE
OALKitlStart
Firmware Init Done.
+OEMInitWatchDogTimer
AT91SAM926x_DispWatchDog 8000!
AT91SAM926x_SetWatchDogConfiguration 10000 => 2560
force clean (@0x806bb614 = 0x0) = FALSE
Sp=ffffc7cc
OEMIoControl: Unsupported Code 0x10100b4 - device 0x0101 func 45
+OALIoCtlHalInitRTC(...)
OEMIoControl: Unsupported Code 0x101008c - device 0x0101 func 35
OEMIoControl: Unsupported Code 0x10100d0 - device 0x0101 func 52
OEMIoControl: Unsupported Code 0x10100f8 - device 0x0101 func 62
+OALIntrRequestSysIntr(1, 0x00035b38 , 0x00000000)
-OALIntrRequestSysIntr(sysIntr = 16)
Handle Event:0x83fb1e3e, sysintr=0x10Master Clock is 58851431 Hz
FMD_GetBlockStatus::Logical block 0x430 is marked as bad
FMD_GetBlockStatus::Logical block 0x4D3 is marked as bad
SPIDriver - SPI_Init - Context: Drivers\Active\04
+OALIntrRequestSysIntr(1, 0x01ec40a8 , 0x00000000)
-OALIntrRequestSysIntr(sysIntr = 18)
SPIDriver - SPI_Init - Context: Drivers\Active\05
SPIDriver - SPI_Init - Context: Drivers\Active\06
USB:OhcdPdd_Init
++InitializeOHCI
+OALIntrRequestSysIntr(1, 0x0602e74c , 0x00000000)
-OALIntrRequestSysIntr(sysIntr = 19)
--InitializeOHCI
+OALIntrRequestSysIntr(1, 0x0602e920 , 0x00000000)
-OALIntrRequestSysIntr(sysIntr = 20)
+OALIntrRequestSysIntr(1, 0x062cfeb8 , 0x00000000)
-OALIntrRequestSysIntr(sysIntr = 21)
Display mode #0, 320x240x4bpp @ 0hzData Abort: Thread=83d8378c Proc=806bc6b0 'gwes.exe'
AKY=00000009 PC=01f2cd60(at91sam9261ek_ddi.dll+0x0001cd60) RA=01f2cd54(at91sam9261ek_ddi.dll+0x0001cd54) BVA=0800083c FSR=00000007
Data Abort: Thread=83d8378c Proc=806bc6b0 'gwes.exe'
AKY=00000009 PC=0004b9bc(gwes.exe+0x0003b9bc) RA=00052f64(gwes.exe+0x00042f64) BVA=08000008 FSR=00000007
AT91SAM926x_usbfn!AT91SAMUsbDevice::ThreadRun: : Attach Detected
/*******/

Could You please analyse the logs and give me the detailed instructions on Platform Builder configuration?
Does "Display mode #0, 320x240x4bpp" mean that Rev A definitions accepted although I have color LCD. Should I set or check this define manually?

Thanks
Ildar
Ildar
Posts: 2
Joined: Thu May 15, 2008 1:13 pm

Thu May 22, 2008 5:49 pm

Solved by Platform Builder and BSP reinstallation with all available updates

Return to “WinCE”

Who is online

Users browsing this forum: No registered users and 2 guests