nandflash reboot issues?

This forum is for users of Atmel's SAM Series and who are interested in using WinCE OS.

Moderator: nferre

monmon
Posts: 2
Joined: Thu Jun 05, 2008 1:17 pm

nandflash reboot issues?

Fri Jun 27, 2008 9:48 am

Hello,

I try to boot a WinCE 6.0 on the nandflash. I build my image with AT91SAM9263EK (Source code) and I select Nandflash bootloader (vs2005 catalog). The compilation work fine.

After that I set eboot (addresse 0x20000) and firstboot. I download the image with target->attach device.
the first time the application start but after that I can't reboot again.
I have this error:
"FMD_DirectRead: Invalid block at sector 2100FMD_DirectRead lasted 10584 ms for 0
x27964d0 bytes (timer granularity is 400)
Launching windows CE image by jumping at address 0x2006d000"

I use vs2005 do download image and samba 2.7 to set eboot (address 0x20000 )and fristboot.

Some body can help me to download image properly?
anschweitzer
Location: Lexington MA, US
Posts: 4
Joined: Thu Feb 07, 2008 7:54 pm

Re: nandflash reboot issues?

Fri Oct 10, 2008 8:24 pm

I just had same problem with Wince50 on 9260. Using SAM-BA to erase NandFlash seemed to make the problem go away.

EBoot seemed to have problem writing all sectors. Many were correct, when comparing read against what was just written. A ways through the image they started being very wrong. memcmp showed different results from read than from write. Perhaps EBoot's erase has problems.?

Return to “WinCE”

Who is online

Users browsing this forum: No registered users and 4 guests