SAM-ICE debugger problems with GNU Toolchain

Discussion around product based on ARM Cortex M3 core.

Moderators: nferre, ncollot

agrealish
Posts: 8
Joined: Thu Jul 28, 2011 4:14 pm

SAM-ICE debugger problems with GNU Toolchain

Fri Jul 29, 2011 4:18 pm

I have had the SAM ICE JTAG debugger up and running but it seems to have stopped working all of a sudden. I am using the GNU toolchain.

In eclipse I am getting messages like:

symbol-file "C:\\Art_Soft\\Atmel ATSAM3U4E USB Development\\eclipse\\USB_Enum_Test\\Project\\bin\\usb-device-core-project-at91sam3u-ek-at91sam3u4-sram.elf"
# Connect to the J-Link gdb server
Undefined command: "". Try "help".
target remote localhost:2331

In the Segger GDB server window the log window is saying:
Connected to 127.0.0.1
SAM-ICE found !
Reading all registers
Read 4 bytes @ address 0x00000000 (Data = 0x20000800)
Read 4 bytes @ address 0x00000000 (Data = 0x20000800)
Select SWD as target interface
Target endianess set to "little endian"
JTAG speed set to 1000 kHz
Resetting target
Sleep 100ms
Select auto JTAG speed (2000 kHz)
ERROR: SAM-ICE can only be used with ATMEL devices
Connection to debugger closed !

Any ideas on what the problem is?

Thanks for any help.
CptTitanic
Posts: 871
Joined: Sat Oct 30, 2010 6:04 pm

Re: SAM-ICE debugger problems with GNU Toolchain

Fri Jul 29, 2011 4:47 pm

If you happen to use an older version of the driver it is possible it doesn't recognize the JTAG/Chip ID for your SAM3. Alternatively it is having a problem reading the assorted ID registers it is trying to probe and consequently rejecting the part as non-ATMEL.
agrealish
Posts: 8
Joined: Thu Jul 28, 2011 4:14 pm

Re: SAM-ICE debugger problems with GNU Toolchain

Mon Aug 01, 2011 3:47 pm

Reinstalling the segger software seemed to fix it so you are probaly right with it being an issue woth the drivers.

Thanks.

Return to “SAM3 Cortex-M3 MCU”

Who is online

Users browsing this forum: No registered users and 2 guests