runtime error with SAM_BA 2.8, programming AT91SAM7S512

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

Posts: 1
Joined: Wed May 27, 2009 8:46 am

runtime error with SAM_BA 2.8, programming AT91SAM7S512

Wed May 27, 2009 9:10 am

I have two questions:
1) When I connect one AT91SAM7S512 to my PC via USB and program it with SAM-BA 2.8 tool, everything is working fine. Only when I connect more than one AT91SAM7S512 to my PC (WinXP), there is an issue: At SAM-BA startup I can choose \USB\ARM0, \USB\ARM1, ... After coosing one of them the GUI appears. Independing if I run now my script and then quit the GUI or if I immediately quit the GUI, an error message appears: "Tclkit, a standalone runtime for Tcl/Tk has encountered a problem and needs to close. We are sorry....". Then I can only choose to send this problem to Microsoft or not. The same happens when I do it with command-line execution. Any ideas?

2) In our massproduction I would like to programm several AT91SAM7S512 in parallel via USB. In detail I am going to start several command-line programs at the same time, the difference is only \ARM0, \ARM1, ... Has anybody tried this? will this work?


Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 2 guests