SAM-BA CDC communications problem on Vista

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

Posts: 1
Joined: Mon May 03, 2010 10:05 am

SAM-BA CDC communications problem on Vista

Mon May 03, 2010 5:25 pm


I have read the FAQ on this forum and I have followed all the instructions for installing SAM-BA on Vista but I still get a communication error F005 when I try to connect. I know that the board works as I can program it in Linux using the SAM7 programming utility. I also know that the Vista driver works as it registers as a virtual com in the device manager. When I rune SAM-BA it picks up the virtual COM port (COM3) so I can select that OK. I can also select the device (AT91SAMS128) from the list. However when I hit connect the GUI disappears. SAM-BA is still running as I can see it in Task Manager as running process but there is no GUI so I have to eventually kill the process in Task Manager.

As mentioned I can program the board in Linux but I really want to be able to work in Vista. Please can anyone help with this.

User avatar
Posts: 162
Joined: Tue Feb 24, 2004 6:27 pm

Re: SAM-BA CDC communications problem on Vista

Fri Jul 16, 2010 11:50 am


Atmel just released SAM-BA v2.10.
Have you tried it with Vista?


Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 1 guest