Page 1 of 1

Change default JTAG speed in SAM-BA 2.15

Posted: Sat Jan 02, 2016 1:45 pm
by panayot

We have a custom board based on the SAM9N21 chip. On the board we have 10 pin ARM JTAG connector instead of 20 pin as on the EK. The 10 pin connector is missing the RTCK signal which is needed for the JTAG Adaptive clocking to work. For this reason, I think, when I try to connect to the board using SAM-BA 2.15 and Segger J-Link ATMEL-ICE JTAG I get "Adaptive clocking timeout" error. The board is live and kicking though, because I can connect using the DBGU serial port and can successfully flash the NAND and run software (Linux). The speed is awfuly slow though, so this method is unusable, in development, for the large Linux images. Also if I run the JLinkCommander tool it connects without problems (w/o adaptive clocking) using 100kHz clock frequency.

From what I've read, I understand that SAM-BA is using adaptie clocking by defalut for SAM9 CPU's. I have tried many things to change the initial JTAG speed inside the low-level and board initialization TCL scripts using the TCL_JlinkSetSpeed command, but with no success. It seems that the very first attempt to connect to the board, where it fails with "Adaptive clocking timeout", is inside the sam-ba.exe with some default settings with which it calls the JlinkArm.dll.

My question is - is there a way to start SAM-BA without using adaptive clocking, but a fixed JTAG clock speed? If not do you have an idea how to workaround the situation?

Thanks in advance.

Best regards,

Re: Change default JTAG speed in SAM-BA 2.15

Posted: Sun Jan 10, 2016 11:01 am
by panayot
In case someone is interested here is what I got from Atmel's support:

Sorry please refer to the sam-ba user guide, for sam9 the JTAG clock is in adaptive mode, this is decided by the sam-ba.dll and the jlinkarm.dll, so this can't be changed.
The only workaround is to follow the correct Jlink pin connection, i.e. adding the RTCK.
Hope this helps, thanks.

Best regards,