Errors updatating dataflash/SDRAM on a custom SAM9260 board

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

sst
Posts: 26
Joined: Fri Mar 16, 2007 3:41 pm

Errors updatating dataflash/SDRAM on a custom SAM9260 board

Tue Apr 17, 2007 4:05 am

I have a custom board based on the SAM9260 with a serial dataflash chip and one 16bit - 64MB SDRAM chip.

I used the 8MB AT45DB081D for the dataflash, and a 64MB MT48LC4M16A2P.

For some reason I am not able to get the DATAFLASH::SelectDataflash AT91C_SPI0_CS1 to find a valid dataflash.
I hooked up all the SPI traces to a logic analyzer and I can see SCK/CS switch on but MOSI remains low and MISO remains high.

Are there any special configuration settings to use a lower speed dataflash? If I run the same function on the EK board, it ID's the chip properly but then EK has a 60Mhz - 64MB dataflash.


The other issue I have is if I try and upload data (test.bin) to the SDRAM using SAM-BA gui, the data written to SDRAM is strange.
e.g. data sent is 0x11223344 but what gets written is 0xFFFF2211 (for some reason the last two bytes are always FFFF)
I guess this might have something to do with the fact that I'm only using a 16bit databus whereas the EK board has a 32bit databus. But I'm not really sure how to tell the micro that I have only one 16bit SDRAM chip.
The bootstrap program seems to have an option to enable 16bit databus width but how can I do this from within SAM-BA, just to test it out.
sst
Posts: 26
Joined: Fri Mar 16, 2007 3:41 pm

Tue Apr 17, 2007 5:14 am

okay I think I solved part of the problem. The TCL scripts to initialize the SDRAM were all for the 32bit bus, I changed the script (per page 156 of the sam9260 datasheet), so now I can see all the data written properly.
The bytes displayed on the SAM-BA-Gui are swapped but a receive file confirmed that it was infact written correctly.


anyone have any clues about the dataflash?

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 3 guests