Setting security bit with SAM-BA from the command line scrip

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

Location: Suwanee, Georgia
Posts: 1
Joined: Thu May 31, 2007 2:51 am

Setting security bit with SAM-BA from the command line scrip

Thu May 31, 2007 3:12 am

Has anyone had any success with setting the security bit from the command line with a SAM-BA TCL script? I created a script that ended with a call to FLASH:ScriptSetSecurityBit for use with a AT91SAM7S64-EK. Erasing worked, unlocking worked, flashing worked, locking worked, and output in the log file even suggested setting the security bit worked. However, the security bit was not set and I was able to actually browse the FLASH and when I checked the register the bit was not set.

I ran the sequence manually in the SAM-BA GUI, ending my sequence with running the Enable Security Bit script (which invokes FLASH:ScriptSetSecurityBit). That worked fine and my memory became inaccessible. I saved that sequency in historyCommand.tcl and executed it from the GUI. It likewise worked fine. Then I tried invoking historyCommand.tcl from the command line. Everything appeared to succeed but the security bit wasn't set.

There's obviously something different between the GUI and the command line invocations of this script. Has anybody got any ideas? Thanks.
Posts: 554
Joined: Thu Dec 02, 2004 2:28 pm

Thu May 31, 2007 8:32 am

i have no experience with your problem in conjunction with sam-ba because from my point of view sam-ba is a pain.
but i would recommend that you set the security bit in your firmware whenever it is started and the security bit isn't set.


Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 2 guests