SAMBA Error with AT91SAM9263-EK

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

mgborer
Posts: 9
Joined: Thu Apr 26, 2007 1:01 pm

SAMBA Error with AT91SAM9263-EK

Tue Jul 24, 2007 4:33 pm

Hello all

on my EvalKit i can write to SDRAM and also in the Dataflash-Card with Samba v2.6. But i have problems in writing to SRAM and FLASH.

Problems with Flash:

The flash type is not recognized, but on the Board i have a SAMSUNG KF92G08U0MPCB8 Flash. So i can not download any code into flash. This is an eval-board. Why is this not working? Not tested?

Samba-Output-Extract:
(AT91-ISP v1.10) 20 % NANDFLASH::Init
-I- Enable the address range of CS3 in HMATRIX user interface
-I- Configure SMC CS3
-I- Clock PIOA
-I- Configure Ready/Busy signal
-I- Configure pull-up
-I- Enable NandFlash
-I- Initialize SDRAM
-I- Configure PIOD as peripheral (D16/D31)
-I- Init MATRIX to support EBI0 CS1 for SDRAM
-I- OUTPUT1: 65546
-I- Init SDRAM
-I- 1. A minimum pause of 200us is provided to precede any signal toggle
-I- OUTPUT2: 65627
-I- 2. A Precharge All command is issued to the SDRAM
-I- *pSDRAM = 0;
-I- 3. Eight Auto-refresh are provided
-I- *pSDRAM = 0;
-I- *pSDRAM = 0;
-I- *pSDRAM = 0;
-I- *pSDRAM = 0;
-I- *pSDRAM = 0;
-I- *pSDRAM = 0;
-I- *pSDRAM = 0;
-I- *pSDRAM = 0;
-I- 4. A mode register cycle is issued to program the SDRAM parameters
-I- *(pSDRAM+0x20) = 0;
-I- 5. Write refresh rate into SDRAMC refresh timer COUNT register
-I- 6. A Normal Mode Command is provided, 3 clocks after tMRD is set
-I- *pSDRAM = 0;
-I- End of Init_SDRAM_48
-I- ReadId
-I- NandFlash ID : 0x00000028
-E- Manufacturer not supported...

(AT91-ISP v1.10) 20 % NANDFLASH::Init
-I- Enable the address range of CS3 in HMATRIX user interface
-I- Configure SMC CS3
-I- Clock PIOA
-I- Configure Ready/Busy signal
-I- Configure pull-up
-I- Enable NandFlash
-I- Initialize SDRAM
-I- SDRAM already initialized
-I- ReadId
-I- NandFlash ID : 0x0012d6a0
-E- Manufacturer not supported...


What do i have to do that it Samba recognizes the correct dataflash type? Why does it read two different NANDFlash ID's?

SRAM


When i download code (led example) on my AT91SAM9263-EK to SRAM and i compare the contents i always get a "dont match".

I write to adress 0x300000. I think this is the correct position for this. Can you give me some advise what to do?

Kind Regards
Mario Borer

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 3 guests