Page 1 of 1

SAM-BA V2.6 with older J-Link

Posted: Mon Sep 10, 2007 9:43 am
by ATTILA
Hi Folks,

I have bought a AT91SAM7S64-EK IAR evaluation KIT a few years ago (2004). This comes with a J-LINK.

I am trying to use this J-LINK with SAM-BA 2.6, but I always get the following warning message:

"The connnected J-Link does not support adaptive clocking. JTAG speed remain at 5kHz".

This is right because this device older. Hardware version is only 3.0. However I don't like to throw out it. Because of this speed is very slow, this solution is unusable for me.

With fix, or auto speed mode I can use it up to 4000kHz (or 2666kHz) under IAR EWB or Eclipse. The speed depends on used JLinkARM.dll.

I there any solution to operate my J-LINK on higher speed via SAM-BA?
How can I turn off the adaptive clocking mode?

Thanks in advance.

Posted: Mon Sep 10, 2007 10:23 am
by gerhardf
hello,
you have to update the firmware of the j-link:

-) download the latest version from:
http://www.segger.com/download_jlink.html

-) start JLink.exe. this will update the firmware of j-link

regards
gerhard

Posted: Mon Sep 10, 2007 11:16 am
by ATTILA
Hi gerhardf,

This was made yet. I have downloaded the latest firmware and I have made an upgrade. It was successful. Unfortunatelly the adaptive clock feature is not SW feature. That is HW. I get this answare from Segger.

So, the only way, if I could config SAM-BA, or SAM-PROG, that it doesn't use adaptive clocking.

Any idea?