linux kernel loading ............. problem..???

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

Posts: 66
Joined: Wed Nov 14, 2007 12:22 pm

linux kernel loading ............. problem..???

Thu Nov 15, 2007 6:48 am


I am using the AT91SAM9261-EK board. I have the linux provided with the CD and its booting. I have downloaded timesys-armv5l-bsp-9261-pkgs and used liunx kernel 2.6.20 to build kernel image ,vmlinux files .

I loaded this image file at 0x20000000 in SDRAM to the target board via tftp but when i tried to run that image it gave error named ""BAd Magic Number"".
I tried to build the image file with some other toolchain also but the same error came again and again.
could anybody help me out what is the exact problem ?
Is there any problem with creating image file or loading into the proper address?.........

Any documents will be really helpful.

With regards
Location: Artec Design LLC, Tallinn, Estonia
Posts: 106
Joined: Thu Aug 09, 2007 10:48 am

Tue Nov 20, 2007 11:39 am

use u-boot's mkimage util on your host PC to package the kernel's zImage to an u-boot image. The mkimage adds a header, where the type of image, memory location to copy the image from storage etc is stored. An optional image compression can be used, too (although with already compressed kernel images it does not make sense).

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 2 guests