SAMBA with 16MHZ over serial port

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

Gustav
Contact:
Location: Denmark
Posts: 8
Joined: Mon Jan 07, 2008 1:14 pm

SAMBA with 16MHZ over serial port

Wed Jan 30, 2008 9:15 pm

Hi folks!
I have self developed PCB for AT91sam7se256, crystal is 16MHZ.
The only difference from ATMEL's kit is this crystal. The remaining ckt. is same.

I am trying to detect board with SAM-BA via COM port (alias RS232/UART).
But all the time i am getting message: "No valid processor ID found".

From previous posts in this forum I understand that SAMBA over USB requires 18.432 MHz, but is that also the case when using the serial port?
GSNT
Location: Germany
Posts: 137
Joined: Mon May 02, 2005 12:17 pm

Wed Jan 30, 2008 10:52 pm

Hi Gustav,

I've checked that with AT91SAM7S64:

SAM-BA 2.6 is working via Serial Port with my DevBoard (16MHz). As far as I understand that's auto-detection. That should work within a range from 3-20MHz (->datasheet).

HTH,
Gerd
Gustav
Contact:
Location: Denmark
Posts: 8
Joined: Mon Jan 07, 2008 1:14 pm

Fri Feb 01, 2008 12:21 am

Hi Gerd,

Thanks for your post. I have got the PCB to work. It was a faulty soldering point under the ARM (it is a BGA).

Amazingly smart with auto-detection of the crystal frequency.

Best,

Gustav
GSNT
Location: Germany
Posts: 137
Joined: Mon May 02, 2005 12:17 pm

Fri Feb 01, 2008 12:36 am

Hi Gustav,

Thanks for your reply. Good to know that you solved it.

Regards,
Gerd

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 2 guests