SAM-BA 2.8 Linux freezes when connecting to AT91SAM9263-ek

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

Posts: 1
Joined: Wed Nov 12, 2008 9:51 am

SAM-BA 2.8 Linux freezes when connecting to AT91SAM9263-ek

Wed Nov 12, 2008 10:07 am

When i try to connect SAM-BA 2.8 to an AT91SAM9263-ek board on Linux, i see the following:

-I- Waiting ...
-I- TCL platform : Linux
-I- SAM-BA OS : linux
-I- Search for device decription files in folder :
-I- /home/ferdy/Datos/Utilidades/sam-ba_cdc_2.8.linux_01/sam-ba_cdc_2.8.linux_01/../lib/devices
-I- Reading AT91SAM9263.tcl
-I- Check the processor ID at address : 0xFFFFEE40
-I- Read chip ID : 0x019607A2 at addr: 0xFFFFEE40
-I- Found device : AT91SAM9263 (Chip ID : 0x019607A0)
-I- Loading applet isp-extram-at91sam9263.bin at address 0x301000

And it freezes forever at this point.
I have tested with a AT91SAM9260-ek and it works perfectly.
I also tried SAM-BA 2.7 for Linux and this version connects ok, so it could be a bug in the 2.8 version for Linux, as windows version works OK.
Besides this, 2.7 version for Linux doesn't work when accessing NandFlash on the AT91SAM9263-ek, so i think it's another bug.
I have tried coping some tcl scripts from working version to non-working version but it wasn't successful, so i suppose the "thing" is in the main program.
If anybody can help , it would be welcome.

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 6 guests