Page 1 of 1

NO valid processor ID found

Posted: Wed Jan 28, 2009 5:39 am
by benjamin.martin
So I have been using an AT91SAM9263-EK dev board, but recently I developed my own board which is very similair. It is similar enough that I thought I could load the dataflash using the same applets in SAM-BA. I can successfully communicate with the bootROM using Hyperterminal.

When I try to open SAM-BA, I get a warning: NO valid processor ID found when I select AT91SAM9263-EK.

Using bootROM, I extracted the chip id manually from the processor. It returned 0x019607A2. I tried adding this number to the devices list, but it didn't help - I still get this warning.

My question is, at what point do the monitors get loaded and executed? If the .bin files have an issue with them (maybe wrong oscillator or something), could this cause this error, or are they only loaded once you do something within SAM-BA (such as send a file). In other words, what happens when SAM-BA loads? What is generating this error? Could it be the monitor bin files, or is it just a TCL script somewhere?


Re: NO valid processor ID found

Posted: Fri Sep 17, 2010 11:26 am
by sjremya
are you able to solve this issue??

I face the same problem.

processor: at91sam9260- [ek]
SAM-BA v2.8

pls revert back