Erase device failed ATSAM4SD32B

Discussion around product based on ARM Cortex M4 core.

Moderators: nferre, ncollot

Posts: 5
Joined: Wed Jul 01, 2015 3:14 pm

Erase device failed ATSAM4SD32B

Mon Feb 08, 2016 6:50 pm


I am currently facing a weird problem.
I have a customized board with a ATSAM4SD32B Microcontroller. For the first weeks of developing my software everything was working perfectly, but currently i am always receiving the same error when trying to erase the MCU (Using Atmel Studio 7):

Timestamp: 2016-02-08 17:43:23.803
Severity: ERROR
ComponentId: 20100
StatusCode: 131103
ModuleName: TCF (TCF command: Device:erase failed.)

Failed to start programming session before chiperase:Unexpected Chip Identifier 0x29a70ee0 (expected 0x29970ee0).

The used SAM-ICE (with the latest software) is always detecting an ATSAM4SD32C instead of the 32B.
I was also searching for a solution in the internet here and changed the XML File with the Identifiers.

Timestamp: 2016-02-08 17:46:37.011
Severity: ERROR
ComponentId: 20100
StatusCode: 131122
ModuleName: TCF (TCF command: Device:erase failed.)

Flash operation failed. Timed out trying to read EEFC_FSR (750 ms).

This is the result here. I also tried to erase the MCU manually by bringing the ERASE Pin high when the MCU is starting (and let it high for about a minute), but i cannot get rid of this error.

Anyone facing the same issue and knows a work around for this?
Side note: I am using 15 customized board which are all working except this one.

Thanks in advance.
Best regards,

Return to “SAM4 Cortex-M4 MCU”

Who is online

Users browsing this forum: No registered users and 4 guests