SAMA5D4EK bootstrap NWD

Discussion around products based on ARM Cortex-A5 core.

Moderator: nferre

Jimmy.Zhu
Posts: 14
Joined: Mon Sep 14, 2015 9:15 am

SAMA5D4EK bootstrap NWD

Sat Apr 09, 2016 12:58 pm

Hi Experts

I build SAMA5D4EK bootstrap 3.7.2 and burn into nandflash with SAMBA, but It's can not start UBOOT and stay here with below log:

Code: Select all

AT91Bootstrap 3.7.2 (Sat Apr  9 17:54:19 CST 2016)


1-Wire: Loading 1-Wire information ...
1-Wire: ROM Searching ... 1-Wire: reset fail
Done, 0x0 1-Wire chips found

WARNING: 1-Wire: No 1-Wire chip found

1-Wire: Using default information

1-Wire: Board sn: 0x1012420, revsion: 0x680820

Auto-Config the TWI Bus by the board
NAND: ONFI flash detected
NAND: Manufacturer ID: 0x2c Chip ID: 0x34
NAND: Disable On-Die ECC
NAND: Initialize PMECC params, cap: 0x8, sector: 0x200
NAND: Image: Copy 0x80000 bytes from 0x40000 to 0x26f00000
NAND: Done to load image
I compare the configuration with the Yacoto bootstrap's, then find the configuration item 'CONFIG_ENTER_NWD' caused my bootstrap failed. I disabled CONFIG_ENTER_NWD and enabled the item ' Redirect All Peripherals Interrupts to AIC' then my bootstrap can start UBOOT now, but I want to known why? Does this will cause new problem?

Code: Select all

              -*- Enable Configure the Matrix          
              [*] Enable Enter the Normal World before Jumping  
              [  ] Redirect All Peripherals Interrupts to AIC  

Thanks

Return to “SAMA5D Cortex-A5 MPU”

Who is online

Users browsing this forum: No registered users and 1 guest