Page 1 of 1

SAMA5D27 SOM1 Custom Board EMMC Not booting

Posted: Fri Sep 06, 2019 8:48 am
by lamasmg
Hi,

Greetings!

We have our own custom board based on SAMA5D27 SOM1 module. We are facing issues to boot the board through emmc on our daughter board on SDHC0 lines. We need to boot from QSPI or EMMC and want the rootfs to be in emmc.

we are using build-root to build our embedded linux.

We have an EMMC of 2gb on daughter board connect to SDHC0.
We have an micro-sd slot on daughter board connected to SDHC1

We tried the following with these options. To build bootstrap for SDHC0,SDHC1,QSPI

We tried the following.

1. We Made 2 user partitions
1.0 One boot partition was already there in emmc
1.1 First primary Partition on users partition of 64M made with mkfs.vfat
1.2 Second Primary Partition on users partition of 1.8 GB with mkfs.ext4
1.3 Made the First partition on user partitions boot.
1.4 And tried the following.
1.4.1.1 Put the boot.bin,u-boot.bin in boot partition
1.4.1.2 Copied the rootfs in Second parttion on user partition of emmc
1.4.2.1 Put the boot.bin,u-boot.bin in first partition of user partitions
1.4.2.2 Copied the rootfs in second partition on user partition of emmc
1.4.3.1 Put the boot.bin,u-boot.bin in som1 qspi
1.4.3.1 Copied the root fs in second partition on user partition of emmc

No matter what we do if we don't put the u-boot.bin in micro-sd we are not able to boot the board.
I tried make clean also. Please help use out as we are kida stuck for days now.

Thanks & Regards
Subhash Lama

Re: SAMA5D27 SOM1 Custom Board EMMC Not booting

Posted: Fri Sep 06, 2019 11:59 pm
by blue_z
lamasmg wrote: We are facing issues to boot the board through emmc on our daughter board on SDHC0 lines.
Then focus on providing detailed information that pertains to that one goal instead of sparse summations of alternate configurations.

lamasmg wrote: We tried the following with these options. To build bootstrap for SDHC0,SDHC1,QSPI
That's an incomplete sentence, and doesn't convey usable information.

Are you cognizant that for each boot device, you must build and install a specific configuration of both AT91Bootstrap and U-Boot?

Regards