SAMD21 with Atmel ICE ? Error 4109 ?

Discussions around product based on ARM Cortex M0+ core.

Moderator: nferre

Posts: 1
Joined: Wed Sep 21, 2016 9:39 am

SAMD21 with Atmel ICE ? Error 4109 ?

Wed Sep 21, 2016 9:42 am

I want to restore bootloader on my feather m0 proto that includes ATSAMD21G18A
I have Atmel-ICE Basic and Atmel Studio 7 on X64 Windows7 Machine.

Atmel SAM port has 100mil 10pin connector.


For programming we need;

1 > Vcc 3.3V > Feather proto's 3V3 pin ( second in pin line )
2> SWDIO > SWDIO on Feather's bottom side
4> SWDCLK > SWDCLK on Feather's bottom side
3,5 > GND > Feather proto's GND pin (4th in pin line)
10 > RST > Feather proto's RST pin (1st in pin line)

I powered Feather with Lipo ( tried with USB too)
Atmel-ICE basic has three lights. Green and red are on.

On Atmel Studio > Tools > Device Programming >
Tool > Atmel-ICE
Device > ATSAMD21G18A
Interface > SWD
and clicked Apply.

When I tried to read device signature, it returned an error ("Unable to enter programming mode.") Code 4109

Target Voltage 2.6V ( From pins directly I measured its 3.2V )

(I connected SWD's pin 5 to GND it will give correct voltage 3.2-3.4 volts)

I changed SWD Clock from 2Mhz to 32Khz, but nothing changed.

Are there any suggestions to try?

Return to “SAM D20 Cortex-M0+ MCU”

Who is online

Users browsing this forum: No registered users and 3 guests