Making QT app for SAMA5D3 Xplained

Moderator: nferre

Posts: 2
Joined: Mon Jul 13, 2015 12:18 pm

Making QT app for SAMA5D3 Xplained

Thu Jul 23, 2015 1:52 pm

I want to compile my own Qt quick apps for SAMA5D3 Xplained board but I have problems to do it.
As far as I undestand I just need the toolchain for Qt to compile my apps. Toolchain can be found at:
I downloaded the file
Running this file installs the toolchain at /opt/poky/1.5.1/

Now I have configured Qt settings:
1. compiler: opt/poky/1.5.1/sysroots/x86-64-pokysdk-linux/usr/bin/arm-pokylinux-gnueabi/arm-poky-linux-gnueabi-gcc
2. debugger: opt/poky/1.5.1/sysroots/x86-64-pokysdk-linux/usr/bin/arm-pokylinux-gnueabi/arm-poky-linux-gnueabi-gdb
3. Qt version: opt/poky/1.5.1/sysroots/x86-64-pokysdk-linux/usr/bin/qmake2
4. Kit with Generic Linux Device which uses compiler, debugger and Qt version below.

First, at Qt version tab it says: "ABI detection failed: Make sure to use a machine compiler when building. No qmlviewer installed"
Second, when I try to build my project error occurs: "c: Command not found"
Third, when I try to go to design tab on Qt creator to modify my app error occurs:
"The executable of the QML Puppet process (/usr/bin/qmlpuppet) cannot be found. Please check your installation. QML Puppet is a process which runs in the background to render the items."

Has anyone any tips to correct these problems?
Posts: 2
Joined: Mon Jul 13, 2015 12:18 pm

Re: Making QT app for SAMA5D3 Xplained

Tue Jul 28, 2015 1:39 pm

I solved all the problems above by installing Qt Creator 2.7.2. I also had to add following line at the first line of
source /opt/poky/1.5.1/environment-setup-cortexa5hf-vfp-poky-linux-gnuabi

When I try to compile Atmel example app ApplicationLauncher everything works fine and the executable works on the board when I launch it by script. However when I try to run my blank Qt Quick 1 project on the board nothing appears on the screen.
Before running the app I have written following lines at the command line:
export QT_QPA_PLATFORM=linuxfb
export QT_QPA_GENERIC_PLUGINS=evdevmouse,evdevtouch:/dev/input/touchscreen0,evdevkeyboard:/dev/input/event0
Finally I run my blank test application by:
./MyTestApp -platform linuxfb -plugin tslib:/dev/input/event1 2>/dev/null &

Nothing appears on the screen and terminal only prints:
[1] 1498

Any ideas how to get my application on the screen?

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 4 guests