ATSAMA5D27-WLSOM1-EK1 low power mode

Moderator: nferre

pgeiem
Posts: 2
Joined: Tue Apr 07, 2020 1:47 pm

ATSAMA5D27-WLSOM1-EK1 low power mode

Tue Apr 07, 2020 2:05 pm

Dear all,

I am using the ATSAMA5D27-WLSOM1-EK1 board. I am using ULP1 mode as described here: https://www.linux4sam.org/bin/view/Linu ... PowerMode1

In my undestanding the power consumption in ULP1 mode should be around 0.3mA for the MPU and typically few mA for the self refresh LPDDR2. When measuring the power consumption on my board I get around 15mA @ 5V on VMain which is way higher than expected.
Note: I still have two LED turned on so they count on but not for that much.

Any idea why I getsuch high current ? is there any documented way to get a complete low power mode with this board ?

Many thanks in advance
blue_z
Location: USA
Posts: 2079
Joined: Thu Apr 19, 2007 10:15 pm

Re: ATSAMA5D27-WLSOM1-EK1 low power mode

Wed Apr 08, 2020 1:44 am

pgeiem wrote: I am using the ATSAMA5D27-WLSOM1-EK1 board.
...
Any idea why I getsuch high current ?
Maybe because you are comparing apples (SiP/SoC) to oranges (a board with radios)?
You also neglect to mention exactly what software (and its configuration) you are using.

pgeiem wrote: In my undestanding the power consumption in ULP1 mode should be ...
You seem to be using SoC specifications and ignoring the radio module, which is a peripheral local to the SoM but still external to the SiP.
Is the ATWILC3000 module even in a low-power state during suspend?
Instead of conjecture, obtain actual baseline measurements for your board (rather than just the SoM or SiP/SoC) using the low-power example from the Software Package. You probably will have to do some code tweaking to support your board with the radio module.

Regards
pgeiem
Posts: 2
Joined: Tue Apr 07, 2020 1:47 pm

Re: ATSAMA5D27-WLSOM1-EK1 low power mode

Fri Apr 24, 2020 6:01 pm

Dear Blue-z,

Thanks for your reply. As this board is an official demo board from Microchip I was thinking low-power mode (even with radio module) is already supported and that radio module will be in sleep mode (if not used).
This is why I am asking if any software already support sleep-mode for this board, according to your reply not.

Thanks
PGE
blue_z
Location: USA
Posts: 2079
Joined: Thu Apr 19, 2007 10:15 pm

Re: ATSAMA5D27-WLSOM1-EK1 low power mode

Tue Apr 28, 2020 6:53 pm

pgeiem wrote: I was thinking low-power mode ... is already supported ..., according to your reply not.
That is not what I wrote.
What I wrote was a question for you to answer.
You need to test your assumptions; check if what you assume is actually true or not.

Study the ATWILC Devices Linux Porting Guide, section 2.3, especially step #2 regarding "enable powersave by default". (AFAICT the Linux4SAM demo kernels, i.e. using sama5_defconfig, do not enable this config value.)
Section 1.1.8 may also be salient.

Regards

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 3 guests