SAM V71 Xplained network issue

Discussions around product based on ARM Cortex M7 core.

Moderator: nferre

Posts: 7
Joined: Thu Jul 10, 2014 1:29 pm

SAM V71 Xplained network issue

Tue Jul 21, 2015 2:59 pm

A few day's ago i started testing the network feature of the SAM V71 Xplained board. There are some examples in the SAMV71-XULT Atmel Studio Software Package 1.3. So i have tried them out.

So far so good. Now i have modified the lwip example (cause i have done some projects in the past with it), but unfortunately there are some problems. I have set up a tcp server port on the board which should send out a data stream captured from a line sensor, but the transmission suddenly stopps after a few seconds of transfer.

So i have took a closer look with wireshark what happens. And it looks as if the SAM doesn't recognize the ACK pakages from my host pc. I can see a lot of duplicate ack packets from my host an tcp retransmissions from the SAM.

So i want to ask, if someone else had these problems. It looks as if the original examples has the same problems if i stress them.
Posts: 7
Joined: Thu Jul 10, 2014 1:29 pm

Re: SAM V71 Xplained network issue

Mon Aug 10, 2015 2:59 pm

Problem solved ... seems to be a bug in the Atmel Softpack version 1.3.

I have updated to the 1.4 Softpack and the release notes shows following bugfixes:
5 Bug fix and improvement
- Fix cache coherency issue in gmac_lwip example
- Fix no sound issue in some audio related examples
- Improved the performance of hsmci_sdcard_fatfs
- Improved the read/write performance of usb_massstorage over 20%
- Updated SDRAM configuration settings

Return to “SAM Cortex-M7 MCU”

Who is online

Users browsing this forum: No registered users and 1 guest