Page 1 of 1

SAME70 problems with USB

Posted: Mon Nov 02, 2015 5:37 pm
by vanekt
Hi all,

I'm developing a custom board with ATSAME70N21A.
Board has standard USB device connector and both 12MHz and 32kHz crystals.

First I tested ROM bootloader. Device connection is detected by host but no other

I modified SAMV71 USB CDC example to compile for SAME70 and flashed by SWD.
Same result as with bootloader, host detects USB FS pull up and thats all.

As last try I used USB host moues example. If I connect 1k5 pull-up resistor to HSDP pin,
I see SOF packets on HSDP by an oscilloscope. Unfortunately there is no inverted signal on HSDM pin.

Datasheet errata reads:
Issue: USB is not working in 64-pin packages
USB does not work in 64-pin package options for the following devices:
Does 100-pin SAME70N21 have a similar issue?

Re: SAME70 problems with USB

Posted: Mon Jul 11, 2016 11:49 am
by Eng.Ahmed
I've a problem which is maybe similar to yours, I developed a board with ATSAME70Q21 144-pin package and when I used the ASF USB CDC library it keeps telling me on windows "Unrecognized usb device (usb device descriptor request failed)".
I still didn't figure what is the descriptor request!

Re: SAME70 problems with USB

Posted: Mon Jul 11, 2016 12:19 pm
by vanekt
Problem I described in the first post was caused by a partial destruction of MCU chip, broken HSDM pin driver (ESD strike?). USB on second board with ATSAME70N21A working without problems.

Re: SAME70 problems with USB

Posted: Mon Jul 11, 2016 4:28 pm
by Eng.Ahmed
If I can ask, how did you operate the USB? Did you use the ASF library or the softpack posted on Atmel's website? I found that different files on that pack but I didn't test them yet, it has something called USB Descriptor which wasn't available in ASF!

Re: SAME70 problems with USB

Posted: Wed Jul 13, 2016 12:08 pm
by Eng.Ahmed
To make sure that I'm working correctly, yesterday I changed the IC and made sure that it didn't face any ESDs! then I generated an ASF USB CDC example and created a user board with my board's peripherals then I built the project and it worked correctly.
Now when I connect the board to the PC I got the same message of device not recognized but I saw something strange, when I connect the USB, the USB LED starts to flash then stops when the PC give me the error message, and when I remove the USB cable the LED starts to flash again then stops, I'm sure that there's something wrong from the PC side but I'm not sure of it, also I tested it on other PCs and still has the same problem, I don't know if the Atmel Studio generates the *.cat & *.inf files correctly or not!