Page 1 of 1

Freezes starting kernel when running compiled u-boot

Posted: Thu Mar 25, 2010 8:11 pm
by npeacock
Can anyone tell me the u-boot version, compiler and other option settings they have used to compile a working uboot for the 9G20?

So far I have tried:

u-boot-2009.11 Compiler=arm-none-eabi- Code Sourcery
u-boot-1.3.4.exp.3 Compiler=arm-elf- 3.4.3 binaries, This seems to be the one the atmel binary was built from
u-boot-1.3.4.exp.4 Compiler=arm-elf- 3.4.3 binaries

In every case my compiled versions seem to get to "Booting the Kernel" and freeze.

I am using different compilers because I'm going with whichever one worked without source modification for the given u-boot source. I'm hoping this indicates it is just some problem with my compilation environment setup. Also if it worked did you compile using a prebuilt binary or a compiler built from source?

Some background...

I am attempting to compile u-boot myself for a AT91SAM9G20. On my custom board the nandflash isn't supported so I'm going to have to add it and recompile, which makes the existing binaries no good. So after having some difficulties with my compiled versions with the flash added, I thought it would be good to first compile a 'clean' uboot so it worked for the eval board. I figured this would eliminate the possibility of hardware problems that may still exist on my custom board and make sure I hadn't messed up u-boot with my changes.

If I use the atmel binary u-boot-1.3.4-exp.3-at91sam9g20ek_2mmc-dataflash_cs1.bin it works fine, and I can actually use this binary to boot up my own linux kernels once I modified the boot env data. In every case my compiled versions seem to get to "Booting the Kernel" and freeze.

I was hoping someone can tell me which version they are using, the compiler and any other things they had to set to get it to boot. Thanks for looking and I would appreciate ANY thoughts about this.

Re: Freezes starting kernel when running compiled u-boot

Posted: Fri Mar 26, 2010 7:20 pm
by npeacock
Turns out I was using a weird kernel. The compiled u-boot was made to load it, so it worked. All the other u-boots wouldn't. I found another kernel binary from Atmel and all my self compiled u-boots seem work fine. I ignored that 2mmc in the file name because everything was working together, turns out it was important to know what it meant.