Openocd at91sam3s4b configuration

Discussion around product based on ARM Cortex M3 core.

Moderators: nferre, ncollot

m.wijlaars
Posts: 2
Joined: Mon Apr 09, 2012 9:21 am

Openocd at91sam3s4b configuration

Mon Apr 09, 2012 12:06 pm

Hi all,

I'm developing a pcb which uses the at91sam3s4b as main processor. I try to talk to it via jtag useing an olimex arm-usb-jtag dongle and openocd.
It is not working, the only response I get is that is finds the right chip ID. Using a osciloscoop I a signal on all relevant jtag pins (TDI,TDO, TMS and CLK), all digital io seems to be there. However I cant open a telnet session to localhost port 4444, I don't get a telnet prompt.
Does anybody have any suggestions?
ngoncalves
Posts: 9
Joined: Tue Apr 03, 2012 3:34 pm

Re: Openocd at91sam3s4b configuration

Mon Apr 09, 2012 5:41 pm

I am not familiar with those tools, but if you can't telnet maybe the firewall is blocking that port.

Windows typically disables ports it does not know.
paranoid_android
Posts: 2
Joined: Wed Apr 18, 2012 11:23 am

Re: Openocd at91sam3s4b configuration

Wed Apr 18, 2012 11:41 am

I've only recently started to use openocd (with a success, however :D ) but I do have an idea:
If you don't have your adapter_khz value set properly in a script, maybe openocd looses connection with the chip and it shutsdown? That might be the reason of your problems with connection to localhost 4444.
m.wijlaars
Posts: 2
Joined: Mon Apr 09, 2012 9:21 am

Re: Openocd at91sam3s4b configuration

Thu Apr 19, 2012 1:15 pm

The problem is solved, the at91sam3 on my PCB was broken, on a new PCB everything works just fine

Return to “SAM3 Cortex-M3 MCU”

Who is online

Users browsing this forum: No registered users and 3 guests