Yockto for SAMA5D3 XPlained

All design tool related questions: compiler, assembler, linker. Embedded programming questions: assembler, C code.

Moderator: nferre

Posts: 1
Joined: Wed Sep 30, 2020 12:58 pm

Yockto for SAMA5D3 XPlained

Wed Sep 30, 2020 1:22 pm

Hello, everyone!

I've got a strange error while trying to make the Yokto microchip headless image.

I do not have much experience with the SAM5D3 CPU, so I've tried to do everything strictly according to the readme at https://github.com/linux4sam/meta-atmel. I work with Ubuntu 20.04 running under VM VirtualBox. When I enter:

MACHINE=sama5d3-xplained bitbake microchip-headless-image

the progress indicator goes up to 99 %, and then freezes. After several hours it gave me a very looooong set of messages finished with:

| {standard input}: Assembler messages:
| {standard input}:1247354: Warning: end of file not at end of a line; newline inserted
| {standard input}:1248156: Error: unknown pseudo-op: `.l21436'
| {standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
| arm-poky-linux-gnueabi-g++: fatal error: Killed signal terminated program cc1plus
| compilation terminated.
| make[1]: *** [tools/v8_gypfiles/v8_initializers.target.mk:248: Release/obj.target/v8_initializers/gen/torque-output-root/torque-generated/../../deps/v8/src/builtins/base-tq-csa.o] Error 1
| make[1]: *** Waiting for unfinished jobs....
| rm 1c72815c29599dda891778c425d689fc1c190ff4.intermediate 09537d73c6d22e6d14c777be749ae5f8f6535a76.intermediate
| make: *** [Makefile:101: node] Error 2
| WARNING: exit code 1 from a shell command.
ERROR: Task (/home/mikhail/poky/poky/../meta-openembedded/meta-oe/recipes-devtools/nodejs/nodejs_12.14.1.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 5428 tasks of which 2245 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
Summary: There were 6 WARNING messages shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

I've tried to give the same bitbake command again and received another not-so-long set of messages with th following errors and warnings:

WARNING: /home/mikhail/poky/poky/../meta-atmel/recipes-bsp/at91bootstrap/at91bootstrap_git.bb: Exception during build_dependencies for T | ETA: --:--:--
WARNING: /home/mikhail/poky/poky/../meta-atmel/recipes-bsp/at91bootstrap/at91bootstrap_git.bb: Error during finalise of /home/mikhail/poky/poky/../meta-atmel/recipes-bsp/at91bootstrap/at91bootstrap_git.bb
WARNING: /home/mikhail/poky/poky/../meta-aws/recipes-sdk/aws-iot-device-sdk-python-v2/aws-iot-device-sdk-python-v2_git.bb: Exception during build_dependencies for AUTOREV
WARNING: /home/mikhail/poky/poky/../meta-aws/recipes-sdk/aws-iot-device-sdk-python-v2/aws-iot-device-sdk-python-v2_git.bb: Error during finalise of /home/mikhail/poky/poky/../meta-aws/recipes-sdk/aws-iot-device-sdk-python-v2/aws-iot-device-sdk-python-v2_git.bb
ERROR: ExpansionError during parsing /home/mikhail/poky/poky/../meta-atmel/recipes-bsp/at91bootstrap/at91bootstrap_git.bb

I've used Goodle and found that it could be a possible solution to give cleanall command and do the same again. I entered

MACHINE=sama5d3-xplained bitbake -c cleanall microchip-headless-image

And got the upper shown set of error messages again.

I've said OK, made the new clean folder and did the same set of "git clone" commands. Than

MACHINE=sama5d3-xplained bitbake microchip-headless-image

and exactly the same result.

What am I doing wrong?

Thank you in advance for your attention

Return to “Development Tools”

Who is online

Users browsing this forum: No registered users and 3 guests