Buildroot mpfr problem

This forum is for users of Microchip MPUs and who are interested in using Linux OS.

Moderator: nferre

heikkihe
Posts: 3
Joined: Fri May 11, 2007 9:02 pm

Buildroot mpfr problem

Sun May 27, 2007 12:02 pm

Hi!

I´m trying to compile an ARM environment for the AT91SAM9260-EK using make_boards-2007-05-21.sh script, which will download the corresponding buildroot package, but after a while the buildroot execution stops and the follwing error is shown:

make[2]: Leaving directory `/usr/at91_buildroot/buildroot-atmel/toolchain_build_arm_small/mpfr-2.2.1-host'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/usr/at91_buildroot/buildroot-atmel/toolchain_build_arm_small/mpfr-2.2.1-host'
make: *** [/usr/at91_buildroot/buildroot-atmel/toolchain_build_arm_small/mpfr/lib/libmpfr.so] Error 2

It seems that there is something wrong with the mpfr, but I have no clue about that. Does anyone have a solution for this?

Thanks,
-Heikki
jpkotta
Location: Fargo, ND, USA
Posts: 41
Joined: Mon Apr 16, 2007 6:34 pm

Fri Jun 01, 2007 1:34 am

edit: double post
Last edited by jpkotta on Fri Jun 01, 2007 1:35 am, edited 1 time in total.
jpkotta
Location: Fargo, ND, USA
Posts: 41
Joined: Mon Apr 16, 2007 6:34 pm

Fri Jun 01, 2007 1:35 am

In my experience, there is something very strangely wrong with buildroot and B=at91sam9260ek (I say strange because I did diffs vs. B=at91sam9260dfc, greps on various CONFIG variables, and I really can't see why it fails). I can't build a toolchain with it. I build a toolchain with B=at91sam9260dfc and then build the target stuff with B=at91sam9260ek.

However, you get further than I do. Can you post more of the make output? Your posting doesn't show what the error was or what caused it.
heikkihe
Posts: 3
Joined: Fri May 11, 2007 9:02 pm

Sat Jun 02, 2007 9:13 am

I also tried to run buildroot scripts with at91sam9260dfc and at91sam9260ek boards but both of them got stuck at some point of the execution. Ek-version won´t find the cross compiler for some reason and the dfc-version has this mpfr problem. I´m running these buildroot scripts on ubuntu-linux.

I put a little longer log files here:
http://kotisivu.dnainternet.fi/heinosa/ ... fc_log.txt
http://kotisivu.dnainternet.fi/heinosa/ ... ek_log.txt

It might be that those problems could easily be solved, but I just really tested those buildroot scripts in the hope of that I could easily get the whole development package. But anyway now I´m building my development environment bit by bit and at this stage I have a working arm-linux cross compiler, which was produced by Kegel´s scripts. I haven´t yet tested if the compiler will produce any working programs, but anyway it seems to compile something.

-Heikki

Return to “LINUX”

Who is online

Users browsing this forum: No registered users and 3 guests